Cocktail Audio™ UK Support Forum

|| www.facebook.com/CocktailAudioUK || www.cocktailaudio.co.uk || www.trustpilot.com/review/cocktailaudio.co.uk ||
It is currently Fri Oct 20, 2017 5:09 am

All times are UTC


Untitled Document

Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Mon May 05, 2014 2:31 pm 
Offline

Joined: Sat Jun 30, 2012 1:55 pm
Posts: 7
I'm having a problem getting my X10 to see my shared music folder on a Windows 7 Home Premium desktop.
X10 is connected to my network wirelessly and is setup on the same workgroup as the desktop.
I can see and access all files on the X10 from the desktop with no problems and I can see and access all files in my shared folder from a Win8 laptop connected to the network.
Of the available network services on the X10 I have Samba Server enabled (with Workgroup set to desktop workgroup), Web Server enabled, UPnP Server disabled, Ftp Server disabled.

I've followed the instructions listed in section 4 here http://cocktailaudio.co.uk/firmware/X10%20Firmware%20Release%20Note_R1560.pdf

Attached is a screenshot of my settings:

I've also followed the additional instructions there to change permissions on my shared folder.

From the 'Add Share' menu on the X10, when I press OK on the remote with the cursor in the 'Server' field I select my desktop and 'guest' is shown in the 'User Name' field. With the cursor in the 'Share' field I press OK again and the screen displays 'Scanning Share...' After a while I get the message 'Failed to scan share!'

I've tried rebooting both the desktop and the X10. I've also tried disabling the firewall on the router and enabling/disabling the 'guest' account (disabled by default) on the desktop. All to no avail. Stumped as to what to try next so I hope you guys and gals can help.


Attachments:
Capture.JPG
Capture.JPG [ 122.48 KiB | Viewed 1879 times ]


Last edited by Astronut on Fri May 09, 2014 3:18 pm, edited 1 time in total.
Top
 Profile  
Reply with quote  
PostPosted: Mon May 05, 2014 10:05 pm 
Offline
User avatar

Joined: Thu Aug 11, 2011 11:13 am
Posts: 265
Try with a user account, perhaps you are not the Admin on your PC.
Also sometimes it depends on how you select the shared folders...
Could be the the root directory isn't shared.
Is SMB enabled on X10?

Video: www.youtube.com/watch?v=B4pv-e0gvsw&lis ... uFZ09tgLkw

_________________
I cast this burden on the Christ within, and go free.......


Top
 Profile  
Reply with quote  
PostPosted: Mon May 05, 2014 10:48 pm 
Offline

Joined: Sat Jun 30, 2012 1:55 pm
Posts: 7
I'm the only one using the desktop so my account already has admin privileges.
If by SMB you mean Samba Server then yes it is enabled. I am able to see and access all files on the X10 from the desktop.

One thing I have noticed after setting the permissions on the shared folder as per instructions in the link in my previous post. I go to the share tab (right-click on shared folder, select 'properties' first), click 'advanced sharing', tick 'share this folder' and then click 'permissions', then 'add' and type 'guest', click 'ok', click 'ok on the previous dialog, then click 'share', add 'guest' from the drop down box then click 'share'. Explorer then says the folder is shared by me, everyone, homegroup and guest as expected. If I then go back in and click 'permissions' after clicking 'advanced sharing' I notice 'guest' is no longer in the list even though explorer is telling me the folder is still shared by 'guest'.

Could it be something to do with the 'homegroup' network settings? Maybe leaving the 'homegroup' and setting the network up as a 'work network' rather than a 'home network' would solve it?

If a laptop connected to the network can see and use my shares, why not the X10 :?


Top
 Profile  
Reply with quote  
PostPosted: Tue May 06, 2014 9:28 pm 
Offline

Joined: Sat Jun 30, 2012 1:55 pm
Posts: 7
Nothings changed since I last posted and now I'm getting the exact same problem as 'tea4one'
http://www.cocktailaudio.co.uk/Forum/viewtopic.php?f=9&t=1064

Is anybody else having similar grief?


Top
 Profile  
Reply with quote  
PostPosted: Tue May 06, 2014 11:41 pm 
Offline

Joined: Sun Jun 24, 2012 6:12 am
Posts: 309
You have probably mixed the guest with the user authentication.
Remove guest or remove the username/permissions.
Your "share" is not properly done


Top
 Profile  
Reply with quote  
PostPosted: Fri May 09, 2014 3:39 pm 
Offline

Joined: Sat Jun 30, 2012 1:55 pm
Posts: 7
Had an epiphany this morning.

I've always called my desktop build HAL9000 (corny I know but what else would a sci-fi fan call it) and my latest Win7 machine is no different.
This time last year I was still running Win2000pro on 10+ year hardware. I've had the X10 for about 2 years and had no problem re-creating shares when I wiped the drive clean a few months back and installed WinXP on 'HAL9000'.

I wondered if there might be a hidden file or something on the X10 storing details (including names) of any machine it's been networked to in the past and the X10 is trying to see my old HAL9000 PC which ran Win2000 and then WinXP.
Despite the numerous firmware updates on the X10 I've never done a 'factory reset' and had no need to do so but I thought it might wipe details of any past networked PC's.

I just tried it and after re-applying all my menu settings, went for broke and tried adding a share. Worked like a charm :) Not only did it see both the laptop and the desktop but it picked all the test shared folders I'd been messing about with and all the default shared folders from the Win7 libraries.

I think Win7 must be a different beast to Win2000 and WinXP as far as networking goes and this might explain why I had no problems with the X10 picking up shares when I upgraded from Win2000 to WinXP (keeping the HAL9000 moniker) as the underlying network protocols/services are similar in both OS's.

I'm now one happy bunny thank you very much :D

btw no need to add 'guest' in shared folder permissions either. Just click 'Advanced sharing' on the sharing tab, tick 'Share this folder', click OK, click 'Share...' click the down arrow on the drop box, click 'Everyone', click 'Add', click 'Share' Done.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron